Version: 2017.1
Руководство экспорта FBX
Импортирование объектов из Cinema 4D

Импортирование обьектов из Maya

Unity natively imports Maya files. To get started, simply place your .mb or .ma file in your project’s Assets folder. When you switch back into Unity, the scene is imported automatically and will show up in the Project view.

Для просмотра вашей модели в Unity, просто перетащите её из окна Project в окно Scene или Hierarchy.

Unity умеет импортировать из Maya:

  1. Все узлы с положением, вращением и масштабом. Центры вращения и имена тоже импортируются.
  2. Меши с вершинными цветами, нормалями и до двух UV развёрток.
  3. Материалы с diffuse цветом и текстурой, множественные материалы для одного меша.
  4. Анимации FK & IK
  5. Анимации, основанные на костях (Bone-based).
  6. Фигуры блендинга (BlendShapes)

Экспортирование Blend Shapes (морфинг) из Maya

  1. Убедитесь, что к экспортируемому мешу применена Blendshape с её целями в надлежащем состоянии
  2. Опционально анимируйте ключевые кадры на узле blendshape, если вам необходимы ключевые кадры анимации Maya
  3. Отметьте animation > Deformations, Skins если требуется, и Morphs в диалоге экспорта FBX

Если вы используете IK для анимации персонажей, вам следует выбрать импортированный .mb файл в окне Project и выбрать Bake IK & Simulation в диалоге Import Settings в инспекторе.

Требования

Чтобы импортировать файлы Maya .mb иb .ma, у вас должна быть установлена Maya на машине, которую вы используете для импорта .mb/.ma файла. Поддерживается Maya 8.0 и новее.

  • Если у вас не установлена Maya, но вы желаете импортировать файл Maya с другой машины, вы можете экспортировать в формат fbx, который Unity умеет импортировать по-умолчанию. Установите последнюю версию FBX Converter для наилучших результатов. Для основных рекомендаций по экспорту, см. Руководство экспорта FBX.

  • После экспорта поместите fbx файл в папку Unity проекта. Unity автоматически импортирует fbx файл. Проверьте настройки импорта FBX в инспекторе, как указано в Руководстве экспорта FBX.

“За кулисами” процесса импорта (для продвинутых пользователей)

Когда Unity импортирует файл Maya, он автоматически запускает Maya в фоне. Затем Unity связывается с Maya для конвертации .mb файла в поддерживаемый формат. Когда вы впервые импортируете файл Maya в Unity, Maya должен запуститься в процессе командной строки, что может занять около 20 секунд, но все последующие Maya файлы будут импортироваться очень быстро.

Решение проблем

  • Старайтесь сохранять сцену простой, попытайтесь работать с файлом, который содержит только те объекты, что вам нужны в Unity.
  • Если ваши меши приводят к проблемам, убедитесь, что вы сконвертировали любые островки (patches), nurbs поверхности и т.д. в полигоны (Modify > Convert + ещё Mesh > Quadragulate/Triangulate). Unity поддерживает только полигоны.
  • В некоторых редких случаях Maya перемешивает историю узлов, что иногда приводит к некорректному экспорту моделей. К счастью, вы довольно легко можете это исправить выбрав Edit->Delete by Type->Non-Deformer History.
  • Unity предпочитает использовать последний формат FBX там где это возможно, так что если у вас возникли какие-то проблемы в импортом некоторых моделей, попробуйте последние версии FBX экспортеров с веб-страницы Autodesk или откатитесь до FBX 2012.
  • Запекание анимации в Maya теперь реализовано через FBX, вместо нативного, что позволяет корректно запекать в FBX формат более сложные анимации. Если вы используете ведомые ключи (driven keys), убедитесь, что на драйверах выставлен хотя бы один ключ, для правильного запекания анимации.
Руководство экспорта FBX
Импортирование объектов из Cinema 4D
Copyright © 2020 Unity Technologies
优美缔软件(上海)有限公司 版权所有
"Unity"、Unity 徽标及其他 Unity 商标是 Unity Technologies 或其附属机构在美国及其他地区的商标或注册商标。其他名称或品牌是其各自所有者的商标。
公安部备案号:
31010902002961