Version: 5.6
Guía para exportar FBX
Importando Objetos desde Cinema 4D

Importando Objetos de Maya

Unity de manera nativa importa archivos Maya. Para comenzar, simplemente coloque su archivo .mb o .ma en la carpeta Assets de su proyecto. Cuando cambie de vuelta a Unity, la escena es importada automáticamente y se mostrará en la Vista del Proyecto (Project View).

Para ver su modelo en Unity, simplemente arrástrelo del Project View a la Scene View o Hierarchy View.

Unity actualmente importa desde Maya:

  1. Todos los nodos con posición, rotación y escala. Los puntos de pivote y nombres también son importados.
  2. Meshes con colores de vértices, normales y hasta 2 conjuntos UV.
  3. Materiales con Texture y color diffuse. Multiplica materiales por mesh.
  4. Animaciones FK & IK
  5. Animaciones basadas en huesos
  6. BlendShapes

Exportando Blend Shapers (morphing) desde Maya

  1. Asegúrese de tener el Blendshape aplicado al mesh exportado con sus objetivos en orden
  2. Opcionalmente anime los keyframes en el nodo blendshape, si usted quiere de keyframes de animación de Maya
  3. Revise animation > Deformations, Skins si se requiere y Morphs en el dialogo de exportación FBX

Si usted está utilizando IK para animar los personajes usted tiene que seleccionar el archivo .mb en el Project View y escoger Bake IK & Simulation en el dialogo de los Import Settings en el Inspector.

Requerimientos

Con el fin de importar archivos Maya .mb y .ma, usted necesita tener Maya instalado en la maquina en dónde usted está utilizando Unity para importar el archivo .mb/.ma . Maya 8.0 y superior es soportado.

  • Si usted no tiene Maya instalado en su maquina pero quiere importar un archivo Maya de otra maquina, usted puede exportar al formato fbx, que Unity importa nativamente. Instale la última versión de FBX para unos mejores resultados. Para unas las lineas guía en general (guidelines) para exportar ver HOWTO_exportFBX.

  • Una vez exportado, coloque el archivo FBX en la carpeta de proyecto de Unity. Unity automáticamente importará el archivo fbx. Revise los import settings (ajustes de importación) de FBX en el inspector como se menciono en HOWTO_exportFBX

Detrás del proceso de importación (Avanzado)

Cuando Unity importa un archivo Maya este ejecutará Maya en el fondo. Unity luego se comunica con Maya para convertir el archivo .mb al formato de Unity que puede leer. La primera vez que usted importa un archivo en Unity, Maya tiene que iniciar un proceso de linea de comando, esto puede tomar alrededor de 20 segundos, pero las importaciones subsecuentes serán rápidas.

Solución de Problemas(Troubleshooting)

  • Mantenga su escena simple, intente trabajar con un archivo que solo contenga los objetos que usted necesite en Unity
  • Si su meshes causa problemas, asegúrese de que haya convertido cualquier patch, superficie nurbs etc a Polígonos (Modify > Convert + también Mesh > Quadragulate/Triangulate) Unity solamente soporta Polígonos.
  • Maya en algunos casos raros daña la historia de nodos, lo cual a veces resultad en que los modelos no sean exportados correctamente. Afortunadamente usted puede arreglar esto fácilmente al seleccionar Edit->Delete by Type->Non-Deformer History.
  • Unity le gusta mantenerse con el último FBX dónde sea posible por lo que si tiene cualquier problema con la importación de algunos modelos, revise por los últimos exportadores FBX de Autodesk website o regrese a FBX 2012
  • El baking de animación en Maya se realiza con FBX en vez de nativamente, lo cual permite que unas animaciones más complejas sean baked adecuadamente al formato FBX. Si usted está utilizando driven keys, asegúrese de configurar al menos una key en sus drivers para que la animación bake apropiadamente
Guía para exportar FBX
Importando Objetos desde Cinema 4D
Copyright © 2020 Unity Technologies
优美缔软件(上海)有限公司 版权所有
"Unity"、Unity 徽标及其他 Unity 商标是 Unity Technologies 或其附属机构在美国及其他地区的商标或注册商标。其他名称或品牌是其各自所有者的商标。
公安部备案号:
31010902002961